Ubuntu 9.04 버전의 경우 subversion의 기본 설정이 1.5으로 되어 있어 소스 컴파일을 통한 설치가 아니면 1.5로 설치가 됩니다. 하지만 subversion의 최근 버전이 1.6이고 subeclipse에서 1.6으로 설치했을 경우 ubuntu의 subversion이 정상적인 작동을 하지 않는 경우가 발생합니다. 

svn: This client is too old to work with working copy '.'.  You need
to get a newer Subversion client, or to downgrade this working copy.
See http://subversion.tigris.org/faq.html#working-copy-format-change
for details.

 저 페이지에서는 1.6으로 업데이트를 하거나 스크립트를 이용해 임시방편으로 사용하라지만 어차피 계속 사용한다면 1.6으로 업데이트를 하는 것이 좋겠지요.

 하지만 직접 소스를 받아서 컴파일 인스톨하는 것은 상당히 번거로운 작업입니다. 그렇기 때문에 apt-get 등의 툴을 이용하는 것이 제일 좋은데요. 이를 위해 launchpad.net에서 해당 버전에 맞는 것을 찾아 /etc/apt/sources.list에 추가 후 apt-get update를 실행한 뒤에 subversion을 설치하시면 됩니다. 일단 ubuntu 9.04 기준으로 

deb http://ppa.launchpad.net/anders-kaseorg/subversion-1.6/ubuntu jaunty main 
deb-src http://ppa.launchpad.net/anders-kaseorg/subversion-1.6/ubuntu jaunty main

  를 추가하시면 되고, 아래 메시지처럼 공개키를 찾을 수 없다는 메시지가 나오면

W: GPG error: http://ppa.launchpad.net jaunty Release: 다음 서명들은 공개키가 없기 때문에 인증할 수 없습니다: NO_PUBKEY 6298AD34413576CB
W: apt-get update를 실행하면 이 문제를 바로잡을 수도 있습니다

해당 공개키값을 적절히 변경하여 다시 업데이트를 하면됩니다.

gpg --keyserver keyserver.ubuntu.com --recv 6298AD34413576CB
gpg --export --armor 6298AD34413576CB | sudo apt-key add -
apt-get update

  1. 유용한 정보인데 쉽게 감이 오질 않네요
    좋은 자료도 감사드리고
    사랑합니다! 행복하세요!!

    2009.08.26 18:22 신고 [ ADDR : EDIT/ DEL : REPLY ]
  2. 어머, 에그 영화예매권 당첨됐넹~!! 축하해욤^^
    전 트래블 파우치 됐어욤^_^ 호호호

    2009.08.31 11:42 신고 [ ADDR : EDIT/ DEL : REPLY ]
    • 와우~ 좋은 글 올렸나보군요.
      전 사진 한두장만 올렸더니 참가상만.ㅋㅋㅋ
      축하드려요~~

      2009.09.01 07:07 신고 [ ADDR : EDIT/ DEL ]
  3. 네이미스

    안녕하세요. 인삼이미지를 찾다가 여기까지 오게되었습니다.
    혹시 인삼이미지를 상업적인용도(전단지제작)에 사용할 수 있을까요?
    요청드리고싶어서 남겨보네요.ㅎㅎ

    2009.09.04 20:48 신고 [ ADDR : EDIT/ DEL : REPLY ]
    • 어떤 사진을 말씀하시는지 알 수 있을까요;
      정작 네이미스님께 연락할 수 있는 방법도 없고;;

      2009.09.05 11:57 신고 [ ADDR : EDIT/ DEL ]
  4. svn과는 관계가 없는내용인가요?

    2010.08.11 10:22 신고 [ ADDR : EDIT/ DEL : REPLY ]

댓글을 달아 주세요